use strict;
my $str = 'ABCEDFG';
my $regex = qr/(?:\G(?!^)|\w{2}(?=\w*$))\K\w(?=\w{2})/mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";