using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^.*btn.*clickable.*$)|(^.*clickable.*btn.*$)";
string input = @"<div class=""clickable""></div>
<div class=""btn clickable""></div>
<div class=""clickable btn""></div>
<div class=""btn btn-default clickable""></div>
<div class=""clickable addButton""></div>
<div class=""btn js-clickable""></div>
<div class=""modalButton btn btn-primary addAction clickable""></div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}