const regex = /(^.*btn.*clickable.*$)|(^.*clickable.*btn.*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^.*btn.*clickable.*$)|(^.*clickable.*btn.*$)', 'gm')
const str = `<div class="clickable"></div>
<div class="btn clickable"></div>
<div class="clickable btn"></div>
<div class="btn btn-default clickable"></div>
<div class="clickable addButton"></div>
<div class="btn js-clickable"></div>
<div class="modalButton btn btn-primary addAction clickable"></div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}