// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^.*btn.*clickable.*$)|(^.*clickable.*btn.*$)").unwrap();
let string = "<div class=\"clickable\"></div>
<div class=\"btn clickable\"></div>
<div class=\"clickable btn\"></div>
<div class=\"btn btn-default clickable\"></div>
<div class=\"clickable addButton\"></div>
<div class=\"btn js-clickable\"></div>
<div class=\"modalButton btn btn-primary addAction clickable\"></div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}