re = /(^.*btn.*clickable.*$)|(^.*clickable.*btn.*$)/m
str = '<div class="clickable"></div>
<div class="btn clickable"></div>
<div class="clickable btn"></div>
<div class="btn btn-default clickable"></div>
<div class="clickable addButton"></div>
<div class="btn js-clickable"></div>
<div class="modalButton btn btn-primary addAction clickable"></div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end