#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?xm)(" & @CRLF & _
"[^ \n].{23}" & @CRLF & _
")"
Local $sString = "База Базовая добыча (вЯк 8) 42370 " & @CRLF & _
"Бурение well_obj1_1_prod (вЯк 8) 42370 " & @CRLF & _
"Бурение well_obj1_1_inj (вЯк 8) 42430 " & @CRLF & _
" ""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)