re = /(
[^ \n].{23}
)/xm
str = 'База Базовая добыча (вЯк 8) 42370
Бурение well_obj1_1_prod (вЯк 8) 42370
Бурение well_obj1_1_inj (вЯк 8) 42430
"'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result