const regex = /(
[^ \n].{23}
)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(
[^ \\n].{23}
)', 'gm')
const str = `База Базовая добыча (вЯк 8) 42370
Бурение well_obj1_1_prod (вЯк 8) 42370
Бурение well_obj1_1_inj (вЯк 8) 42430
"`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);