const regex = /(?<=:)\d+(?=:\w+:(?:true|false))/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=:)\\d+(?=:\\w+:(?:true|false))', 'gmi')
const str = `"number" : 4aac4c35-8e3e-4730-8364-381884d6f20f:OP:QUAL:117804471:PON:false
"number" : 2ef526e0-3e9b-11ea-b77f-2e728ce88125:OP:QUAL:456:PON:false
"number" : 375cf754-3e9b-11ea-b77f-2e728ce88125:OP:QUAL:345675:PING:true
"number" : 4178d884-3e9b-11ea-b77f-2e728ce88125:OP:QUAL:117804471:PON:false
"number" : 3f3990e0-3e9b-11ea-b77f-2e728ce88125:OP:QUAL:117804471:PON:false`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}