$re = '/(?<=:)\d+(?=:\w+:(?:true|false))/mi';
$str = '"number" : 4aac4c35-8e3e-4730-8364-381884d6f20f:OP:QUAL:117804471:PON:false
"number" : 2ef526e0-3e9b-11ea-b77f-2e728ce88125:OP:QUAL:456:PON:false
"number" : 375cf754-3e9b-11ea-b77f-2e728ce88125:OP:QUAL:345675:PING:true
"number" : 4178d884-3e9b-11ea-b77f-2e728ce88125:OP:QUAL:117804471:PON:false
"number" : 3f3990e0-3e9b-11ea-b77f-2e728ce88125:OP:QUAL:117804471:PON:false';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);