# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=:)\d+(?=:\w+:(?:true|false))"
test_str = ("\"number\" : 4aac4c35-8e3e-4730-8364-381884d6f20f:OP:QUAL:117804471:PON:false\n"
"\"number\" : 2ef526e0-3e9b-11ea-b77f-2e728ce88125:OP:QUAL:456:PON:false\n"
"\"number\" : 375cf754-3e9b-11ea-b77f-2e728ce88125:OP:QUAL:345675:PING:true\n"
"\"number\" : 4178d884-3e9b-11ea-b77f-2e728ce88125:OP:QUAL:117804471:PON:false\n"
"\"number\" : 3f3990e0-3e9b-11ea-b77f-2e728ce88125:OP:QUAL:117804471:PON:false")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.