import Foundation
let pattern = #"(?<=:)\d+(?=:\w+:(?:true|false))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
"number" : 4aac4c35-8e3e-4730-8364-381884d6f20f:OP:QUAL:117804471:PON:false
"number" : 2ef526e0-3e9b-11ea-b77f-2e728ce88125:OP:QUAL:456:PON:false
"number" : 375cf754-3e9b-11ea-b77f-2e728ce88125:OP:QUAL:345675:PING:true
"number" : 4178d884-3e9b-11ea-b77f-2e728ce88125:OP:QUAL:117804471:PON:false
"number" : 3f3990e0-3e9b-11ea-b77f-2e728ce88125:OP:QUAL:117804471:PON:false
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)