use strict;
my $str = '"number" : 4aac4c35-8e3e-4730-8364-381884d6f20f:OP:QUAL:117804471:PON:false
"number" : 2ef526e0-3e9b-11ea-b77f-2e728ce88125:OP:QUAL:456:PON:false
"number" : 375cf754-3e9b-11ea-b77f-2e728ce88125:OP:QUAL:345675:PING:true
"number" : 4178d884-3e9b-11ea-b77f-2e728ce88125:OP:QUAL:117804471:PON:false
"number" : 3f3990e0-3e9b-11ea-b77f-2e728ce88125:OP:QUAL:117804471:PON:false';
my $regex = qr/(?<=:)\d+(?=:\w+:(?:true|false))/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}