#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?:www|https?)\S*"
Local $sString = "www.example.com" & @CRLF & _
"http://example.com" & @CRLF & _
"https://example.com"
Local $sSubst = "XXX"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)