use strict;
my $str = 'www.example.com
http://example.com
https://example.com';
my $regex = qr/(?:www|https?)\S*/ip;
my $subst = 'XXX';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";