const regex = /(?:www|https?)\S*/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:www|https?)\\S*', 'gi')
const str = `www.example.com
http://example.com
https://example.com`;
const subst = `XXX`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);