import Foundation
let pattern = #"(?:www|https?)\S*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
www.example.com
http://example.com
https://example.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"XXX"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)