re = /(?:www|https?)\S*/i
str = 'www.example.com
http://example.com
https://example.com'
subst = 'XXX'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result