#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/zxp\/companies\/.+?\/queries\/.*(?<!\btype=inbox\b[^\r\n/]*)$"
Local $sString = "/zxp/companies/432523/queries/4344?read=2&type=inbox" & @CRLF & _
"/zxp/companies/432523/queries/4344?type=inbox&read=2" & @CRLF & _
"/zxp/companies/432523/queries/4344?type=query&read=2" & @CRLF & _
"/zxp/companies/432523/queries/4344" & @CRLF & _
"/zxp/companies/432523/buildings/4344?type=query&read=2" & @CRLF & _
"/zxp/companies/432523/buildings/4344" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")