import re
regex = re.compile(r"^\/zxp\/companies\/.+?\/queries\/.*(?<!\btype=inbox\b[^\r\n/]*)$", flags=re.MULTILINE)
test_str = ("/zxp/companies/432523/queries/4344?read=2&type=inbox\n"
"/zxp/companies/432523/queries/4344?type=inbox&read=2\n"
"/zxp/companies/432523/queries/4344?type=query&read=2\n"
"/zxp/companies/432523/queries/4344\n"
"/zxp/companies/432523/buildings/4344?type=query&read=2\n"
"/zxp/companies/432523/buildings/4344\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")