const regex = /^\/zxp\/companies\/.+?\/queries\/.*(?<!\btype=inbox\b[^\r\n/]*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/zxp\\\/companies\\\/.+?\\\/queries\\\/.*(?<!\\btype=inbox\\b[^\\r\\n\/]*)$', 'gm')
const str = `/zxp/companies/432523/queries/4344?read=2&type=inbox
/zxp/companies/432523/queries/4344?type=inbox&read=2
/zxp/companies/432523/queries/4344?type=query&read=2
/zxp/companies/432523/queries/4344
/zxp/companies/432523/buildings/4344?type=query&read=2
/zxp/companies/432523/buildings/4344
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}