use strict;
my $str = '/zxp/companies/432523/queries/4344?read=2&type=inbox
/zxp/companies/432523/queries/4344?type=inbox&read=2
/zxp/companies/432523/queries/4344?type=query&read=2
/zxp/companies/432523/queries/4344
/zxp/companies/432523/buildings/4344?type=query&read=2
/zxp/companies/432523/buildings/4344
';
my $regex = qr/^\/zxp\/companies\/.+?\/queries\/.*(?<!\btype=inbox\b[^\r\n/]*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}