import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/zxp\\/companies\\/.+?\\/queries\\/.*(?<!\\btype=inbox\\b[^\\r\\n/]*)$";
final String string = "/zxp/companies/432523/queries/4344?read=2&type=inbox\n"
+ "/zxp/companies/432523/queries/4344?type=inbox&read=2\n"
+ "/zxp/companies/432523/queries/4344?type=query&read=2\n"
+ "/zxp/companies/432523/queries/4344\n"
+ "/zxp/companies/432523/buildings/4344?type=query&read=2\n"
+ "/zxp/companies/432523/buildings/4344\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}