#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is).*(\border\s+by\s+.*)"
Local $sString = "select id,(ROW_NUMBER() OVER (ORDER BY (SELECT 1))) AS SerialNo,name,address from customer order by name"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")