package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is).*(\border\s+by\s+.*)`)
var str = `select id,(ROW_NUMBER() OVER (ORDER BY (SELECT 1))) AS SerialNo,name,address from customer order by name`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}