const regex = /.*(\border\s+by\s+.*)/is;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(\\border\\s+by\\s+.*)', 'is')
const str = `select id,(ROW_NUMBER() OVER (ORDER BY (SELECT 1))) AS SerialNo,name,address from customer order by name`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}