re = /.*(\border\s+by\s+.*)/i
str = 'select id,(ROW_NUMBER() OVER (ORDER BY (SELECT 1))) AS SerialNo,name,address from customer order by name'
# Print the match result
str.match(re) do |match|
puts match.to_s
end