// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?is).*(\border\s+by\s+.*)").unwrap();
let string = "select id,(ROW_NUMBER() OVER (ORDER BY (SELECT 1))) AS SerialNo,name,address from customer order by name";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}