# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(this)(?|.*(test)|.*())/$1 $2/g;t' <<< "this is a test
this is just junk
more junk"