use strict;
my $str = 'this is a test
this is just junk
more junk';
my $regex = qr/(this)(?|.*(test)|.*())/p;
my $subst = '$1 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";