$re = '/(this)(?|.*(test)|.*())/';
$str = 'this is a test
this is just junk
more junk';
$subst = "$1 $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;