#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(this)(?|.*(test)|.*())"
Local $sString = "this is a test" & @CRLF & _
"" & @CRLF & _
"this is just junk" & @CRLF & _
"" & @CRLF & _
"more junk"
Local $sSubst = "$1 $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)