re = /(this)(?|.*(test)|.*())/
str = 'this is a test
this is just junk
more junk'
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result