# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?:(?:0+(:))+0*|0+\B)/$1/gim;t' <<< "2001:0db8:abcd:0012:0000:0000:0000:0001
2001:0db8:abcd:0012:0000:0000:0000:00a2
2001:0db8:abcd:0012:0000:0000:0000:00ff
How about zeros at the end?
2001:db8:abcd:12:0000:0000
2001:db8:abcd:12:0000
"