use strict;
my $str = '2001:0db8:abcd:0012:0000:0000:0000:0001
2001:0db8:abcd:0012:0000:0000:0000:00a2
2001:0db8:abcd:0012:0000:0000:0000:00ff
How about zeros at the end?
2001:db8:abcd:12:0000:0000
2001:db8:abcd:12:0000
';
my $regex = qr/\b(?:(?:0+(:))+0*|0+\B)/imp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";