package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)\b(?:(?:0+(:))+0*|0+\B)`)
var str = `2001:0db8:abcd:0012:0000:0000:0000:0001
2001:0db8:abcd:0012:0000:0000:0000:00a2
2001:0db8:abcd:0012:0000:0000:0000:00ff
How about zeros at the end?
2001:db8:abcd:12:0000:0000
2001:db8:abcd:12:0000
`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}