#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)\b(?:(?:0+(:))+0*|0+\B)"
Local $sString = "2001:0db8:abcd:0012:0000:0000:0000:0001" & @CRLF & _
"2001:0db8:abcd:0012:0000:0000:0000:00a2" & @CRLF & _
"2001:0db8:abcd:0012:0000:0000:0000:00ff" & @CRLF & _
"" & @CRLF & _
"How about zeros at the end?" & @CRLF & _
"2001:db8:abcd:12:0000:0000" & @CRLF & _
"2001:db8:abcd:12:0000" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)