$re = '/\b(?:(?:0+(:))+0*|0+\B)/im';
$str = '2001:0db8:abcd:0012:0000:0000:0000:0001
2001:0db8:abcd:0012:0000:0000:0000:00a2
2001:0db8:abcd:0012:0000:0000:0000:00ff
How about zeros at the end?
2001:db8:abcd:12:0000:0000
2001:db8:abcd:12:0000
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;