package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\s\S].*?)(<.+>)`)
var str = `<span id="3">
HELLO THERE
<span id="5">
Other stuff
<span id="6">
Other Stuff
<span id="7">
Other sutff`
var substitution = "$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}