#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d+)\s?(Ans|Años|Years Old|Year Old|Years D'âge|Yo|-?Years-Old)(\s|$)"
Local $sString = "Barbeito Boal Old Reserve 10 Year Old (Medium Sweet) Madeira Wine" & @CRLF & _
"Butler Nephew’s 20 Years Old Port Wine" & @CRLF & _
""
Local $sSubst = " $1 Years "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)