# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d+)\s?(Ans|Años|Years Old|Year Old|Years D'âge|Yo|-?Years-Old)(\s|$)"
test_str = ("Barbeito Boal Old Reserve 10 Year Old (Medium Sweet) Madeira Wine\n"
	"Butler Nephew’s 20 Years Old Port Wine\n")
subst = " $1 Years "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
    print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.