const regex = /(\d+)\s?(Ans|Años|Years Old|Year Old|Years D'âge|Yo|-?Years-Old)(\s|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)\\s?(Ans|Años|Years Old|Year Old|Years D\'âge|Yo|-?Years-Old)(\\s|$)', 'gm')
const str = `Barbeito Boal Old Reserve 10 Year Old (Medium Sweet) Madeira Wine
Butler Nephew’s 20 Years Old Port Wine
`;
const subst = ` $1 Years `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);