// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+)\s?(Ans|Años|Years Old|Year Old|Years D'âge|Yo|-?Years-Old)(\s|$)").unwrap();
let string = "Barbeito Boal Old Reserve 10 Year Old (Medium Sweet) Madeira Wine
Butler Nephew’s 20 Years Old Port Wine
";
let substitution = " $1 Years ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}