re = /(\d+)\s?(Ans|Años|Years Old|Year Old|Years D'âge|Yo|-?Years-Old)(\s|$)/m
str = 'Barbeito Boal Old Reserve 10 Year Old (Medium Sweet) Madeira Wine
Butler Nephew’s 20 Years Old Port Wine
'
subst = ' $1 Years '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result