using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[.*\](\r|\n|\r\n)[a-zA-Z0-9_=.\r\n]*";
string input = @"[SectionA]
KeyName_1=10.01
KeyName_2=20.2
KeyName_3=15.6
[SectionB]
KeyName_4=10.01
KeyName_5=20.2
KeyName_6=15.6
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}