package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[.*\](\r|\n|\r\n)[a-zA-Z0-9_=.\r\n]*`)
var str = `[SectionA]
KeyName_1=10.01
KeyName_2=20.2
KeyName_3=15.6
[SectionB]
KeyName_4=10.01
KeyName_5=20.2
KeyName_6=15.6
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}