const regex = /^\[.*\](\r|\n|\r\n)[a-zA-Z0-9_=.\r\n]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\[.*\\](\\r|\\n|\\r\\n)[a-zA-Z0-9_=.\\r\\n]*', 'gm')
const str = `[SectionA]
KeyName_1=10.01
KeyName_2=20.2
KeyName_3=15.6
[SectionB]
KeyName_4=10.01
KeyName_5=20.2
KeyName_6=15.6
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}