use strict;
my $str = '[SectionA]
KeyName_1=10.01
KeyName_2=20.2
KeyName_3=15.6
[SectionB]
KeyName_4=10.01
KeyName_5=20.2
KeyName_6=15.6
';
my $regex = qr/^\[.*\](\r|\n|\r\n)[a-zA-Z0-9_=.\r\n]*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}