import Foundation
let pattern = #"^\[.*\](\r|\n|\r\n)[a-zA-Z0-9_=.\r\n]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[SectionA]
KeyName_1=10.01
KeyName_2=20.2
KeyName_3=15.6
[SectionB]
KeyName_4=10.01
KeyName_5=20.2
KeyName_6=15.6
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)