using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\beat food\b";
string substitution = @"food eat";
string input = @"eat food and she eat food so he can eat food";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}